The AltaGrade Blog

Chaos Tool Suite (ctools) - Moderately critical - Access bypass - SA-CONTRIB-2021-015

Chaos Tool Suite (ctools) - Moderately critical - Access bypass - SA-CONTRIB-2021-015

Project: Chaos Tool Suite (ctools)
Date: 2021-June-16
Security risk: Moderately critical 13∕25 
Vulnerability: Access bypass

Description

Chaos tool suite (ctools) module provides a number of APIs and extensions for Drupal, its 8.x-3.x branch is a start from scratch to evaluate the features of ctools that didn't make it into Drupal Core 8.0.x and port them.

Read More

Linky Revision UI - Moderately critical - Access bypass - SA-CONTRIB-2021-016

Linky Revision UI - Moderately critical - Access bypass - SA-CONTRIB-2021-016

Project: Linky Revision UI
Date: 2021-June-16
Security risk: Moderately critical 11∕25 
Vulnerability: Access bypass

Description

This module provides a revision UI to Linky entities.

The module doesn't sufficiently respect access restrictions to certain entities when used in conjunction with specific modules.

This vulnerability is mitigated by the fact that an attacker must have a role with any of the permissions provided by Linky Revision UI, and another affected module must be enabled.

Read More

Frequently Asked Questions - Moderately critical - Cross Site Scripting - SA-CONTRIB-2021-012

Frequently Asked Questions - Moderately critical - Cross Site Scripting - SA-CONTRIB-2021-012

Project: Frequently Asked Questions
Date: 2021-June-02
Security risk: Moderately critical 11∕25
Vulnerability: Cross Site Scripting

Description

The Frequently Asked Questions (faq) module allows users, with appropriate permissions, to create question and answer pairs which they want displayed on the 'faq' page. The 'faq' page is automatically generated from the FAQ nodes configured. Basic Views layouts are also provided and can be customized via the Views UI (rather than via the module settings page).

Read More

Open Social - SQL Injection & Authentication Bypass vulnarabilities - SA-CONTRIB-2021-010 & SA-CONTRIB-2021-011

Open Social - SQL Injection & Authentication Bypass vulnarabilities - SA-CONTRIB-2021-010 & SA-CONTRIB-2021-011

Open Social - Moderately critical - SQL Injection - SA-CONTRIB-2021-010

Project: Open Social
Date: 2021-June-02
Security risk: Moderately critical 11∕25 AC:Complex/A:User/CI:All/II:None/E:Theoretical/TD:Default
Vulnerability: SQL Injection

Description

This Open Social distribution provides a turn-key system for building customized social networks.

The module doesn't sufficiently process data in certain circumstances.

Read More

Backdrop core - Moderately critical - Cross Site Scripting

Backdrop core - Moderately critical - Cross Site Scripting

Date: Wednesday, May 26th, 2021
Security risk: Moderately Critical
Advisory ID: BACKDROP-SA-CORE-2021-003
Vulnerability: Cross Site Scripting

Versions affected

  • Backdrop Core 1.19.x versions prior to 1.19.1
  • Backdrop Core 1.18.x versions prior to 1.18.5

Backdrop versions 1.17 and prior do not receive security coverage.

Description

Backdrop core uses the third-party CKEditor library. This library has an error in parsing HTML that could lead to an XSS attack.

Read More

WordPress 5.7.2 Security Release

WordPress 5.7.2 Security Release

WordPress 5.7.2 is now available. This security release features one security fix. Because this is a security release, it is recommended that you update your sites immediately. All versions since WordPress 3.7 have also been updated.

WordPress 5.7.2 is a short-cycle security release. The next major release will be version 5.8. You can update to WordPress 5.7.2 by downloading from WordPress.org, or visit your Dashboard → Updates and click Update Now.

If you have sites that support automatic background updates, they’ve already started the update process.

Read More

Gutenberg - Critical - Access bypass - SA-CONTRIB-2021-007

Gutenberg - Critical - Access bypass - SA-CONTRIB-2021-007

Project: Gutenberg
Version: 8.x-2.x-dev, 8.x-1.x-dev
Date: 2021-May-12
Security risk: Critical 18∕25
Vulnerability: Access bypass

Description

This module provides a new UI experience for node editing using the Gutenberg Editor library.

The module did not correctly validate access rules in certain situations allowing anonymous users to delete blocks.

Solution

Install the latest version:

Read More

Pages