Drupal core - Critical - Multiple vulnerabilities - SA-CORE-2022-016
Project: Drupal core Date: 2022-September-28 Security risk: Critical 18∕25 Vulnerability: Multiple vulnerabilities Affected versions: >= 8.0.0 <9.3.22 || >= 9.4.0 <9.4.7 CVE IDs: CVE-2022-39261
Drupal core's code extending Twig has also been updated to mitigate a related vulnerability.
Multiple vulnerabilities are possible if an untrusted user has access to write Twig code, including potential unauthorized read access to private files, the contents of other files on the server, or database credentials.
The vulnerability is mitigated by the fact that an exploit is only possible in Drupal core with a restricted access administrative permission. Additional exploit paths for the same vulnerability may exist with contributed or custom code that allows users to write Twig templates.
Install the latest version:
- If you are using Drupal 9.4, update to Drupal 9.4.7.
- If you are using Drupal 9.3, update to Drupal 9.3.22.
All versions of Drupal 9 prior to 9.3.x are end-of-life and do not receive security coverage. Note that Drupal 8 has reached its end of life.
Drupal 7 core does not include Twig and therefore is not affected.