Drupal core - Moderately critical - Third-party libraries - SA-CORE-2021-005

Drupal core - Moderately critical - Third-party libraries - SA-CORE-2021-005

Project: Drupal core
Date: 2021-August-12
Security risk: Moderately critical 13∕25
Vulnerability: Third-party libraries


The Drupal project uses the CKEditor, library for WYSIWYG editing. CKEditor has released a security update that impacts Drupal.

Vulnerabilities are possible if Drupal is configured to allow use of the CKEditor library for WYSIWYG editing. An attacker that can create or edit content (even without access to CKEditor themselves) may be able to exploit one or more Cross-Site Scripting (XSS) vulnerabilities to target users with access to the WYSIWYG CKEditor, including site admins with privileged access.

For more information, see CKEditor's announcement of the release.


Install the latest version:

If you are using Drupal 9.2, update to Drupal 9.2.4.
If you are using Drupal 9.1, update to Drupal 9.1.12.
If you are using Drupal 8.9, update to Drupal 8.9.18.

Versions of Drupal 8 prior to 8.9.x and versions of Drupal 9 prior to 9.1.x are end-of-life and do not receive security coverage.

Drupal 7 core is not affected, although Drupal 7, 8, and 9 site owners should review their site following the protocol for managing external libraries and plugins previously suggested by the Drupal Security Team, as contributed projects may use additional CKEditor plugins not packaged in Drupal core.

We value your opinion. Please add your feedback.